System Requirements „ÄČ Software requirements
 
Software requirements
* 
Please make certain that the most up-to-date Service Pack from Microsoft is installed when using the Windows system. Install the security updates provided by Microsoft on a regular basis.
* 
Special requirements apply to the SwyxWare for Data Center server components.
Please refer to the following table to find out on which operating system the components of SwyxWare are running:
Operating system
SwyxWare*
SwyxIt!*
SwyxWare Administration
SwyxDesktop for MacOS
Windows 7
no
yes**
yes
no
Windows 8
no
yes**
yes
no
Windows 10
no
yes**
yes
no
Server 2012 R2
yes
yes**
yes
no
Server 2016
yes
yes**
yes
no
Mac OS
no
no
no
yes
*The fax components SwyxFax Server or SwyxFax Client are installed together with SwyxServer or SwyxIt!.
** Application sharing is not possible directly in SwyxIt!. For further information, please refer to the SwyxIt! documentation.
(A list of supported operating systems can be found in the knowledgebase article:
Supported operating systems (overview)
https://www.swyx.com/products/support/knowledge-base/article-details/swyxknowledge/kb4094.html
 
You can obtain more information on this subject from your Swyx partner or support.
Microsoft .NET Framework
As of SwyxWare version 2015, an installation of Microsoft .NET Framework v4.5.2 is required for SwyxServer and any other SwyxWarecomponents. .NET Framework can also be downloaded subsequently via the Windows update feature, or from the SwyxWare DVD.
SQL Database for the user data
SwyxServer needs a Microsoft SQL database for storing the user and configuration data. You can choose from a variety of options:
* Microsoft SQL Server 2016 Express (or Microsoft SQL Server 2014 Express on Windows Server 2012 R2)
Microsoft SQL 2016 (2014) Express can be downloaded directly from the SwyxWare DVD. It can manage databases up to a total volume of 10 GB.
* 
If you want to subsequently set up a standby scenario, please upgrade the Microsoft SQL Server Express Edition for the master system to a SQL Server Standard Edition. The SQL Agent installed along with this is needed for the database synchronization. On both servers, the function "Database Services - Replication" must be selected during the installation of the SQL Server. The standby system can continue to work with a Microsoft SQL Server Express database. See Requirements for the SwyxStandby option pack.
* Microsoft SQL Server 2016 Express (or Microsoft SQL Server 2014 Express on Windows Server 2012)
For larger installations, please use at least Microsoft SQL Server 2016 (2014) Standard Edition.
The database server must be set up before the installation of SwyxWare.
* 
The existing SQL server is not updated in a SwyxWare update.