L.4 Installation and Operation of Swyx with VMware vSphere
This section describes how to install and run Swyx in a vSphere virtual machine and configure it for high availability with vSphere.
Swyx is installed in its entirety with SQL Server Express in a virtual machine. Alternatively, Swyx can be installed without SQL Express, and the database can be run on an existing SQL Server cluster.
vSphere High Availability and vSphere Fault Tolerance
VMware vSphere offers various functions to make virtual machines highly available:
*vSphere High Availability and vSphere Fault Tolerance
monitors the VM and the application running in it and restarts the VM if the operating system or application in the VM stops responding.
*vSphere Fault Tolerance
maintains a constantly updated copy of the virtual machine on a second host and automatically switches to the copy if one host fails.
Swyx HealthMonitor
To ensure that vSphere can monitor not only the VM but also the Swyx running on it, install the Swyx HealthMonitor service in addition to Swyx. It monitors the Swyx services and manages the vSphere Heartbeat interface. If all Swyx services are available, HealthMonitor sends a "heartbeat" every twenty seconds via the vSphere Heartbeat interface. If one of the services stops responding, the heartbeat fails. vSphere uses the failure of the heartbeat to detect a nonresponding application and restart the VM.
 
In addition, you should always combine a vSphere HA/FT solution with a VM backup solution.