L.6.1 Configuring Swyx Services
|
Service Error
|
HealthMonitor not installed
|
HealthMonitor installed
|
|---|---|---|
|
1st Service Failure
|
Service is restarted
|
Service is restarted
|
|
2nd Service Failure
|
Service is restarted
|
No action
|
|
Subsequent service outages
|
Service is restarted
|
No action
|
This setting ensures that a Swyx service that is unexpectedly terminated will be restarted once by Windows. If a service is terminated more than once, it will not be restarted. The HealthMonitor detects the missing response of the service and stops the VMWare Heartbeat so that the VM is restarted.
Example:
The service is queried every 10 seconds (probingIntervalInSeconds=10). If more than 2 queries remain without a response (LessThanOrEqual=2), the service has less than 30s to restart.
When you add Swyx services, run the HealthMonitor installation script again to adjust the restart configuration for the new service accordingly. Alternatively, you can manually customize the restart options using the Windows Services Manager.