L.6.1 Configuring Swyx Services
In a standard Swyx installation, Windows is configured so that Swyx services are automatically restarted by Windows if they are unexpectedly terminated.
The HealthMonitor installation script modifies this configuration for all Swyx services monitored by HealthMonitor as follows:
Service Error
HealthMonitor not installed
HealthMonitor installed
1st Service Failure
Service is restarted
Service is restarted
2nd Service Failure
Service is restarted
No action
Subsequent service outages
Service is restarted
No action
This setting ensures that a Swyx service that is unexpectedly terminated will be restarted once by Windows. If a service is terminated more than once, it will not be restarted. The HealthMonitor detects the missing response of the service and stops the VMWare Heartbeat so that the VM is restarted.
If, in your deployment scenario, restarting a service takes longer than the HealthMonitor monitoring threshold, adjust the HealthMonitor configuration accordingly:
1 Open the configuration file "appSettings.json" in a text editor.
2 In the "HealthRules" section, find the entry for the service which monitoring you want to customize.
3 Increase the value "LessThanOrEqual" so that "probingIntervalSeconds" of the service (see configuration of the service in the section "Probes" in the "appSettings.json" file) multiplied by "LessThanOrEqual" is smaller than the value, the service needs for restarting.
Example:
The service is queried every 10 seconds (probingIntervalInSeconds=10). If more than 2 queries remain without a response (LessThanOrEqual=2), the service has less than 30s to restart.
 
When you add Swyx services, run the HealthMonitor installation script again to adjust the restart configuration for the new service accordingly. Alternatively, you can manually customize the restart options using the Windows Services Manager.